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FE 257 LAB 8   
Raster Data Applications 
Watershed Delineation 
 
In this lab you will continue to familiarize yourself with raster data structures and the Spatial Analyst. The datasets for 
this lab are drawn from one of the sample databases in the text, “Geographic Information Systems: Applications in 
Forestry and Natural Resource Management.”  The datasets represent a fictional area named the Brown Tract and are 
well suited for our lab applications. 
 
Open the Windows Explorer and navigate to the t:\teach\classes\fe257\gislab8 location on the forestry network. Right 
click on this folder and choose Copy from the menu that appears. Use Windows Explorer to navigate to your workspace 
folder. For most of you this will be located on the N:\ drive and will have the same name as your user name- for me it’s 
N:\wingm. Right click on your FE257 workspace folder and choose Paste from the menu that appears. This should copy 
the gislab8 folder and all its nested folders and files into your workspace.  
 
Start a new ArcGIS Pro session and select New Blank Map. Save your map document as Lab8.aprx and store is under 
your workspace\gislab8 folder. 
 
If necessary, go to Insert > Add Folder to connect to your workspace\gislab8 folder. Use the Add Data button to add 
boundary.shp and streams.shp to your map. You can adjust the symbology of the layers to match your preferences. 
Rename your data frame “Watershed” and save your map project. 
 
All distance and elevation units in the Lab 8 datasets are U.S. feet (survey feet). 
 

 
 
Importing Raster Files 
 
We’ll need to access the Brown Tract DEM. The pixels in the Brown Tract DEM represent elevation values for each 10m 
per side “square” within the forested area of interest.  
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Add the BrownTractDEM file to your Map session. Rename this layer “Brown Tract DEM” in your Contents window.  
 

 
 
Spatial Analyst 
 
For this lab we will use geoprocessing tools available through the Spatial Analyst extension. Like in Lab 7, you can go to 
Project > Licensing to check for the extension. 
 

 
 
Watershed Delineation 
 
A watershed is defined as an area that shares a common drainage. For a variety of management purposes, foresters are 
often asked to define and measure watershed areas. Watershed boundaries and measurements are used to estimate 
overland flow, identify landslide-prone sites, and to split landscapes into hydrologic regions of influence. 
 
The definition of a watershed boundary will be a function of landscape slope and aspect; the basic components of 
topography. For many years, foresters were limited to working with hardcopy topographic maps or their own field 
observations to define watershed areas. With the availability of 10 and 30m resolution DEMs for the entire U.S. and 
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modern GIS capabilities, we can compute watershed boundaries and areas much more quickly, and potentially much 
more accurately. 
 
In this lab you will use the Brown Tract DEM to create a watershed boundary following two different methods. The first 
method will involve heads-up delineation of a watershed boundary. This heads-up method will require you, the user, to 
evaluate contour lines and available spatial databases to guide your expertise in digitizing a watershed boundary. The 
second method will take advantage of some of the automated raster processing tools available through the Spatial 
Analyst. We’ll then compare the results of these two methods. The Brown Tract is our area of interest. 
 
Using Elevation Contours and Other Spatial Data to Locate a Watershed Boundary 
 
The Streams layer within the Brown Tract has several components to it. We’re going to focus our initial efforts on a 
stream stem in the southwest portion. We’ll first select the stream sections we’re interested in, then we’ll convert those 
sections into a separate layer. As a first step, make the Streams layer the only selectable layer. Right click on Streams > 
Selection > Make this the only selectable layer. You can also use the List by Selection tab in the Contents window to 
make sure that only the Streams layer is checked under “Selection.” 
 

 
 
The graphic below shows the stream sections of interest for the lab exercise in the southwest corner of the boundary 
area. Zoom in to the same spatial extent as the graphic and use the Select tool to select these stream sections. Holding 
the Shift key will allow you to select multiple features with different mouse clicks. 
 

 
 Once you select these sections, switch back to the List by Drawing Order tab in your Contents window. 
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Create a new shapefile containing the stream sections you selected. 
 

1. Right click on the Streams layer in the Contents window. 
2. Select Data > Export Features. 
3. In the Export Features dialog box, make the Input Features Streams and save the output to your gislab8 folder as 

SW_streams.shp. Click Run. 
 

 
 

Rename the new layer SW Streams and adjust its symbology so you can see it clearly. If necessary, turn off the Streams 
layer and right click on SW Streams in the Contents window and select Zoom to Layer. Click Clear in the Selection menu. 
 
Turn the Boundary layer off. 
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Creating Elevation Contours 
 
You will now heads-up digitize a watershed area for the SW Streams layer. The initial step in this process will be to 
create elevation contours guiding our digitizing. 
 

1. In the Geoprocessing window, search for the Contour tool like in Lab 7. 
2. This will open the Contour dialog box. Set the Contour Interval to 40 (to mimic a USGS 7.5’ topographic map) 

and save the output as contour40.shp to your gislab8 folder. Click Run. 
 

 
 

The contour40 layer should appear in your map and the Contents window. 
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Heads-Up Watershed Delineation 
 
Examine the output and its relation to the SW streams layer. Use the contours, stream network of interest, and 
surrounding stream networks to guide your process of delineating a watershed. If you examine each of these layers in 
your map frame, you’ll notice that the contour shapes create V’s that usually define flow paths and directions. Typically, 
water flows from the bottom point of the V shape to the top (ridge to valley, high to low elevation). Saddle shapes 
(contour lines that look like ovals or circles) usually indicate ridge lines and can sometimes be used to define the 
boundary between watersheds. 
 
We can also use surrounding stream network sections to help identify the ridge line that divides one watershed from 
another. Turn the Streams layer back on and change its Symbology to help differentiate between SW Streams and 
Streams like in the graphic below. Evaluate your data layers to determine where the ridges surround your watershed. 
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If you’re uncertain about defining a portion of a watershed boundary, think about which direction water would flow if 
you dumped a bucket of water on the uncertain location. This may help you place a watershed boundary line. Using 
these topographic clues and approaches, we should be able to heads-up digitize a watershed for the SW streams layer. 
 
Start by locating the lowest section of the SW streams layer where it flows into the main stem - this is where we’ll begin 
our watershed. Try to visualize, from this starting location, where you would draw the watershed boundary line. Make 
sure you are zoomed out far enough to see all the sections of the layers you’ll need. This includes the stream sections of 
the network to the north of the SW Streams layer.  
 
You will first create a new polygon feature class to store the heads-up watershed polygon you draw. First, make sure you 
have established a folder connection to your gislab8 folder (Insert menu > Add Folder). In the Catalog window, right click 
on the gislab8 folder and select New > Shapefile. 
 
The Create Feature Class dialogue box should open. Navigate to your gislab8 workspace under Feature Class Location. 
The Feature Class Name will be SW_Streamshed. Geometry Type is Polygon. Leave all other defaults except for 
Coordinate System; in the drop-down menu, select Current Map [Watershed] and the field will populate with NAD 1927. 
Click Run. 
 

 
 
The SW_Streamshed polygon feature class should appear in your Contents window; rename it “SW Streamshed.” If you 
open the attribute table, you’ll notice the feature class doesn’t contain any features because we haven’t created any yet. 
Drawing our heads-up watershed polygon will create a polygon feature in the feature class. 
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You will now use the Create Features window to digitize your heads-up watershed polygon. Go to the Edit menu > 
Create. This will open the Create Features window displaying all the templates for editable feature layers in your map 
project. We are only concerned with the SW Streamshed layer. 
 

 
 

 
 
Click on the SW Streamshed template to expand it and open the Active Template menu. Click the Polygon icon to begin 
drawing a polygon around the watershed area. 
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Once you’ve activated the Polygon tool, your cursor will enable you to draw a polygon by single clicking around the 
watershed in your map display area. Each subsequent click establishes a turning point, or vertex, for your polygon. 
When you approach the spot where you began drawing your polygon, a double click will close the polygon. Digitize your 
watershed using this tool and the delineation instructions provided above. 
 

 
 
After you’ve used the Polygon tool to draw a watershed polygon, you can use the Edit Vertices tool and Modify Features 
window to adjust the shape if necessary. 
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 Move a vertex by clicking it and dragging it. 
 

 Add a new vertex by right clicking on the edge of the polygon and selecting Add Vertex. 
 

 An existing vertex can be removed by right clicking on a vertex and selecting Delete Vertex. 
 

 You can delete the entire polygon by using the Select tool to select it and right clicking > Delete. 
 

When you’re finished digitizing, save your edits in the Edit menu. Save your map project as well. 
 

 
 

Adjust the watershed Symbology if necessary. If preferred, you can adjust the transparency of SW Streamshed by 
clicking on the layer in the Contents window and going to the Feature Layer > Appearance menu. Use the transparency 
slider to adjust the transparency to your liking. 
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Updating Watershed Area Measurements 
 
As always, when we create or edit a shapefile, we must update the area measurements (polygon area, line length, etc.) 
Use the Calculate Geometry tool for this purpose. 
 
The adding or updating of measurements is something you should do to a layer every time you create a new polygon 
or line layer, or change the dimensions (size) of an existing polygon or line layer. 
  
Let’s add area measurements to the SW Streamshed layer. 

1. Open the SW Streamshed attribute table. Click the Add Field button. 
2. Under Field Name, type Area. Leave all other defaults and click Save. An Area field should appear in the SW 

Streamshed attribute table. 
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3. Right click on the new area field and select Calculate Geometry. 
4. In the Calculate Geometry window, the Input Features are SW Streamshed. The Target Field is Area and the 

Property is Area. Change the Area Unit to Acres; in the future you can change the Area Unit to whatever suits 
your application. Click Run. 
 

 
 
Your area calculation should produce a value of roughly 860 acres. If your value is slightly above or below this number, 
this is to be expected; no two students’ area calculations will be the same since each individual drew a unique polygon. 
As long as your polygon shape looks roughly correct and your value is in the mid to high 800s, your steps were correct. 
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Close the attribute table. Save your map project. 
 
Using a DEM to Automate Watershed Delineation 
 
In this portion of the lab, we’ll let the Brown Tract DEM do some of the work for us in watershed delineation. While the 
DEM will provide information about changes in elevation from one pixel to another, we’ll mine this information for data 
regarding the direction in which water would flow over the landscape. We’ll use the Flow Direction tool for this task. 
 
The Flow Direction tool systematically assesses the entire DEM raster using a moving window surrounding sets of pixels. 
The tool compares differences in elevation between pixels within the window. It keeps track of the differences in values 
to determine which pixels are the downslope neighbors of others. Using this information, ArcGIS Pro computes a flow 
direction raster where each pixel represents the expected direction water will flow across the landscape based on 
elevation differences between pixels and their downslope neighbors. The following ArcGIS Pro documentation (ESRI) 
conceptualizes the D8 flow direction model, which we will use in the next step: 
 

 
 
Search for Flow Direction in the Geoprocessing Window. 
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In the Flow Direction dialogue box, make the Input Surface Raster Brown Tract DEM. Save the Output Flow Direction 
Raster to your gislab8 folder as FIowDirBrown. Leave all other defaults; we will use the D8 Flow Direction Type featured 
in the above ArcGIS Pro documentation. Click Run. 
 

 
 

The FlowDirBrown raster should appear in your Contents window. You should now have a flow direction raster for the 
entire Brown Tract DEM. Examine the results. As stated in the D8 flow direction model documentation, the raster is 
classified into nine categories based on elevation differences between pixels. The pixel colors and patterns should 
generally reflect the landscape topography made clear through the DEM shading and contour lines. 
 

 
 
Save your map project.  
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You will now use the Watershed tool to create a computer-automated watershed delineation based on your new flow 
direction raster. Search for Watershed in the Geoprocessing window. 
 

 
 
Look at the Watershed dialogue box; you will notice we have a problem. We need both a flow direction raster and an 
input raster to generate a watershed.  
 

 
 
We currently have our flow direction raster but no input raster. We must first create an input raster to successfully run 
the Watershed tool. The input raster will be the location for which to calculate a watershed, aka our SW Streams layer. 
However, our SW Streams layer is in a vector format. We’ll use some Spatial Analyst tools to convert this file into a 
raster format that will serve as our input raster for the Watershed tool. 
 
First, we will modify Raster Analysis options in the Geoprocessing Environment settings to ensure that the new output 
raster file will meet our needs. Go to the Analysis menu > Environments. 
 

 
 

In the Environments dialogue box, find the Raster Analysis section. 
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Under Cell Size heading, click the drop down and select “Same as layer Brown Tract DEM.” Leave all other defaults and 
click OK. This ensures that the raster we create from SW Streams will have the same cell size as Brown Tract DEM. 
 

 
 

Now you’ll convert the SW Streams layer to a raster data structure as needed for the Watershed tool. First, create a new 
field in the SW Streams attribute table containing the same value for all stream features. 
 
Open the attribute table for SW Streams and click Add Field. Under Field Name, type SW. Data Type will be Short and 
Precision will be 2. Leave all other defaults and click Save. 
 

 
 
A new field called SW should now exist in your SW Streams attribute table.  
 

 
 

Right click on the SW field header and select Calculate Field. Enter 1 in the “SW =” box and click Run. Now check the SW 
Streams attribute table to see that every cell in the SW column is populated with 1. Close the attribute table. 
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Create a Raster File of SW Streams 
 
In the Geoprocessing window, search for Feature to Raster. 
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In the Feature to Raster dialog box, make SW Streams the Input Features. The Field will be SW. Direct the output to your 
gislab8 folder and name it sw_strm_grid. The Output Cell Size should automatically populate with the Brown Tract DEM 
file since we set those parameters earlier in the Environments menu. Click Run. 

 

 
 
 

The output should be added to your Contents window. Zoom to the extent of the SW Streamshed layer and turn off all 
layers except the Brown Tract DEM and new raster layer sw_strm_grid. Rename the new layer SW Streams Grid. You 
should see that the vector SW Streams layer was converted to raster pixels overlaying those in the Brown Tract DEM. 
 

 
 
We now have all the files to create a computer-automated watershed delineation with the Watershed tool. Again, 
search for Watershed in the Geoprocessing window. 
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In the Watershed dialogue box, make FlowDirBrown the Input D8 Flow Direction Raster. The Input Raster is SW Streams 
Grid. The Pour Point Field is VALUE. Save the output to your gislab8 folder with the name sw_strm_gshed. Click Run. 
 

 
 
Examine the results. Turn the SW Streams layer on so you can see the streams of interest. Turn the contour40 layer on 
to see how well the computer recognized topography. Turn the SW Streamshed layer on to compare the computer-
digitized results to your heads-up digitizing results. When finished organizing your layers they should look like this: 
 

 
 
Which digitization method more accurately represents the SW Streams Watershed? Consider the strengths and 
weaknesses of both methods. Save your map project. 
 
Use the Raster to Polygon tool to convert the new sw_strm_gshed raster file to a vector polygon feature. Search for 
Raster to Polygon in the Geoprocessing window. 
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In the Raster to Polygon dialogue box, make sw_strm_gshed the Input Raster. The Field is VALUE. Direct the Output 
Polygon Features to your gislab8 folder with the name sw_strm_wshed2.shp. Click Run. 

 

 
 
The new polygon layer will appear in your Contents window. It should directly overlay the sw_strm_gshed raster. Do not 
rename the layer or else your future area calculation will not work! Save your map project. 
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Now calculate the area of your computer-delineated watershed and compare it to your heads-up digitized version. 
Follow the same steps as before on Pages 11-12 to complete this task. The area of the DEM-derived watershed should 
be about 810 acres. 
 

 
 
Finish the lab exercise by preparing a new data frame for your lab assignment called Watershed 2. You have the option 
to delete the files you created in the lab exercise using the Catalog window. These files may confound your data 
management abilities for the lab assignment; however, you may want to use some of them for your assignment analyses 
(like the flow direction raster) instead of creating completely new files. 
 
Save your map project. 
 
 
 
Lab 8 Application. This is a team assignment. Please include your names and lab day and time (e.g. Tuesday 10 AM) on 
your submission. This lab is due at the beginning of next week’s lab.  
 
Use both the heads-up digitizing AND DEM-based (computer digitized) watershed delineation methods presented in 
this lab to generate two watershed delineations for the following set of streams in the Brown Tract: 
 

 
 
Create map of your two watershed results. The map should contain both your heads-up digitized watershed and the 
computer-created watershed; the polygons should overlap. You can use the transparency slider to display both at the 
same time if you wish, or leave them solid colored since one polygon should be smaller than the other. All other map 
elements for a quality map should also be present! 6 points. 


