
1 
 

FE 257 LAB 7 
The Geodatabase 
Working with Spatial Analyst 
Calculating Elevation and Slope Values for Forested Roads, Streams, and Stands 
 
In this lab you will work with the Spatial Analyst extension. The data for this lab come from McDonald Forest and will 
build upon our earlier data. We will be working with spatial data from the shapefiles we manipulated in Lab 6: McDonald 
Forest boundary, streams, roads, and stands. 
 
Open Windows Explorer and navigate to the t:\teach\classes\fe257\gislab7 location on the forestry network. Right click 
on this folder and choose Copy from the menu that appears. Use Explorer to navigate to your workspace folder. For 
most of you this will be located on the N:\ drive and will have the same name as your user name- for me it’s N:\nicolatk. 
Right click on your workspace folder and choose Paste from the menu that appears. This should copy the gislab7 folder 
and all enclosed data files into your workspace.  
 
Importing Raster Files 
 
The DEM we will work with is from Peavy Arboretum in the McDonald Forest. It contains elevation values for the forest 
at a 10 m per cell side raster resolution. Measurement units within the layers you will work with are US survey feet.  
 
Open ArcGIS Pro and start a new blank Map. Save it as Lab7.aprx in your gislab7 workspace. 
 
If necessary, go to the Insert menu and choose the Add Folder button to establish a connection to your gislab7 folder. 
 
Use the Add Data button to add boundary, roads, stands, streams and peavygrid to the data frame. Rename your data 
frame “Peavy” and the layers Boundary, Roads, Stands, Streams, and Peavy DEM. 
 
Zoom to the extent of the layers you added. Reorder the layers so that Roads and Streams are overlaid on Peavy DEM. 
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Using a Geodatabase 
 
In this lab we will work with the ArcGIS spatial data structure called a geodatabase. The geodatabase is a multiuser 
relational database system and the primary format for spatial data editing and management (ESRI). A geodatabase acts 
as a container for all the files in your project. It is compatible with many different file types like shapefiles, tables, and 
rasters. The geodatabase also keeps track of relationships between these files and improves compatibility between 
datasets. Therefore, geodatabases increase geoprocessing and spatial modeling capabilities. Overall it is best practice to 
create a geodatabase for each project and fill it with your required files, perform spatial analyses within geodatabase, 
and save output files to the geodatabase. 
 
ArcGIS Pro automatically creates an accompanying geodatabase for new projects. When you saved Lab7.aprx earlier, the 
program created a number of files associated with the project, for example a Toolbox (.tbx) file. You can view these files 
by opening Windows Explorer and browsing to your gislab7 folder. One of the accompanying files created with the Lab 7 
project was Lab7.gdb. This is the geodatabase for Lab7.aprx. The geodatabase file extension is .gdb. 
 
The Catalog module is the ArcGIS interface for working with geodatabases. Even though we will ultimately use the 
geodatabase Lab7.gdb, it is still important to know how to create a new geodatabase, so we will practice this process. 
 
Make sure your Catalog window is visible on the right; if not, go to View > Catalog Pane. Browse to and expand the 
Folders list and find your gislab7 folder (it should automatically show up; if not, go to the Insert menu > Add Folder and 
connect to it). When you expand your gislab7 folder, Lab7.gdb, the mac_lamb folder and its enclosed files should appear 
in the folder, similar to the graphic below. 
 

 
 
To practice creating a new geodatabase, right click on the gislab7 folder and select New > File Geodatabase. This will 
create a new geodatabase in the gislab7 folder that you can rename. However, we will use the premade Lab7.gdb for 
our project, so you can right click and Delete the new one you created since it was just for practice. 
 
Rename Lab7.gdb to McDonald.gdb. Save your project. 
 

 
 

Converting Shapefiles to Geodatabases 
 
In the Catalog pane, right click on the boundary shapefile, choose Export, and select “Feature Class(es) to Geodatabase.” 
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This will open a dialog box for converting multiple files into a geodatabase at the same time. Make the Input Features 
the four shapefiles in the mac_lamb folder: Boundary, Roads, Streams and Stands. Make the Output Geodatabase the 
McDonald geodatabase. Click Run. 
 

 
 

Save your project, close out of ArcGIS Pro, restart the program and reopen your project. In the Catalog pane you 
should now see the four shapefiles in the McDonald geodatabase. If you do not restart the program, you likely won’t see 
the change in locations. 
 

 
 

Converting Rasters to Geodatabases 
 
The raster peavygrid is in a different data format than the shapefiles and will need to be converted into the geodatabase 
separately. Unfortunately, the function to right click on the raster and convert it directly does not exist in ArcCatalog. 
Instead, search for the Raster to Geodatabase tool in the Geoprocessing window. 
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In the dialog box that appears, browse to your mac_lamb folder and make peavygrid and elevgrid the Input Rasters. 
Browse to McDonald.gdb as the Output Geodatabase. Click Run. 
 

  
 
Save your project, close out of ArcGIS Pro, restart the program and reopen your project. In the Catalog pane you 
should now see the two rasters in the McDonald geodatabase. If you do not restart the program, you likely won’t see 
the change in locations. 

 
 
Delete the rasters and shapefiles from your mac_lamb folder. They should disappear from your Contents window. 
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You should now have a file structure that looks like the graphic below. We will work strictly within McDonald.gdb for the 
rest of the lab. 

 
 
Go to Insert > Add Folder to connect to McDonald.gdb. Use the Add Data button to navigate to your McDonald 
geodatabase and add Boundary, Roads, Stands, Streams, and peavygrid to your Peavy data frame. Don’t worry about 
elevgrid for now; this file is for the homework. Your data frame should look the same as before when you pulled the 
files from the mac_lamb folder. 

  
If necessary, rename the files as you did in the middle of Page 1. Zoom to the extent of Peavy DEM and turn off all other 
layers from view. 
 
Save your map project. 
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Accessing the Spatial Analyst Extension 
 
The Spatial Analyst extension allows us to work with rasters and perform advanced analyses. The extension comes 
packaged with ArcGIS Pro provided you have paid for the additional software. If you haven’t, you can purchase the 
Spatial Analyst extension at any time and add it to an ArcGIS product. Let’s view this extension under Project > Licensing.  

 
 
You can access the Spatial Analyst tools through the Geoprocessing window. 
 
Examining DEMs 
 
Similar to the way ArcGIS Pro displays shapefiles, a default legend is created when you add a raster grid to your 
Contents. The grid we’re examining (Peavy DEM) is a digital elevation model (DEM) with each raster cell coded as an 
elevation value. The units displayed in the Contents legend are the elevation values. The units are US survey feet- you 
can’t tell what the units are by just looking at the legend and/or DEM map- you have to look at the metadata or 
projection information for Peavy DEM. 
 
We can alter Peavy DEM’s symbology by right clicking on it in the Contents window and selecting Properties > 
Symbology. 
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By default, ArcMap uses a continuous (“stretched”) grayscale to represent the elevation values. By looking at the 
information in the Symbology tab, we can see that high elevation values are shaded lightly while low values are dark. In 
addition, we see the minimum and maximum elevation values. 
 
We can use the Symbology interface to alter the raster grid’s display. In the Primary Symbology box, choose Classify. This 
will allow us to split the elevation values into categories rather treating them continuously. 
 
Set the number of classes to 7 and change the Method from Natural Breaks to Quantile. This should create seven 
categories, organized from low to high, each with an equal number of observations (pixels per class). Choose a color 
ramp from the Color Scheme drop down that effectively communicates the elevation gradient across quantiles. 
 

 
 
One of the unique features of this dialog box is being able to see the distribution of cell values under the Histogram tab. 
You can experiment with the “More” drop down menu to show statistics, reverse symbol order and reverse values 
according to your display preferences. 
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When finished your interface should resemble the graphic below. 
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Creating Elevation Contours 
 
Let’s create elevation contours that approximate the 40-foot intervals used by the USGS 7.5-minute quadrangle series 
maps. We’ll need to access Spatial Analyst functions through the Geoprocessing window. Search for Contour and select 
the Spatial Analyst Tools option. 
 

 
 
The Input Surface is a reference to the dataset we are basing our contours on, Peavy DEM. Set the Contour Interval to 40 
and direct the output to your McDonald geodatabase with the name contour40. 
 

 
 
A new layer from this process should be added to your Contents. 
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Open the attribute table for contour40 and notice that an elevation value (CONTOUR) was added to each row.  
 

 
 
Close the table and save your project. 



11 
 

Creating a Shaded Relief Map 
 
A shaded relief map displays the landscape topography. The result approximates a 3D scene. You can create one of 
these by searching for Hillshade in the Geoprocessing window and choosing the Spatial Analyst Tools option. 
 

 
 
A dialog box will open where you can manipulate the direction and height of the illumination source. The Azimuth 
describes the angle, relative to the landscape, from which the landscape will be illuminated. The Altitude describes the 
vertical angle of the sun- a low small angle would approximate morning or evening times whereas a large angle would 
be closer to noon. The z factor allows us to exaggerate the relief effect. Let’s change the Azimuth to 220 but accept the 
other defaults. Direct the output raster to your geodatabase and title it hillshade. Click Run. 
 

   
 
This should add a new layer to your Contents. Your map should look similar to the one below. You may want to toggle 
the contour layer off to get a closer look at your landscape surface. 
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Save your project. 
 
Examining Histograms 
 
Let’s turn both of these new layers off (contour40 and hillshade) and find out more about the Peavy DEM layer. Right 
click on the Peavy DEM layer in the Contents window to reopen the Symbology tab. In the lower part of the Symbology 
window, click the Histogram tab to return to the image featured on Page 8. Click the More drop-down menu to 
experiment with reversing symbol order and values to your liking. 
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Our histogram tells us that we had seven elevation categories. Since we chose a quantile classification method, we 
should have an equal number of observations in each category. Bear in mind that if we changed the classification 
method, these results would change too. 
 
Click on the More drop down and select Show Statistics to bring up the raster statistics. 
 

 
Close the Symbology window. 
 
Let’s do some clean-up at this point. First delete the contour40 and hillshade layers by right clicking on them and 
choosing Remove. Make sure the Stands layer in your Contents is below the Streams and Roads layers but above the 
Peavy DEM layer. Make the Stands, Streams, and Roads visible. 
 
Save your project. 
 

 
 
Analyzing Vector and Raster Data Simultaneously 
 
One of the useful features of Spatial Analyst is its ability to work with vector data and raster grids in the same analysis. 
The Roads, Streams, and Stands layers are all vector files but we can extract information from the Peavy DEM layer that 
relates to these vector layers. Let’s find out what the average elevation of the stand units in this area are. Search for 
Zonal Statistics as Table from the Geoprocessing window. 
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Choose Stands as the Input Feature Zone Data. We need to pick a variable from the Stands attribute table that uniquely 
identifies each stand unit: STANDID. Make this selection for the Zone Field. By default, Peavy DEM should be the Value 
raster but make a change if something else is selected in your project. Direct the output to McDonald.gdb, name the 
output “standelev,” and click Run. 
 

  
 
Our operation above told the Spatial Analyst to look at each of the polygons in the Stands layer as identified by the field 
STANDID. If two polygons shared the same attribute for this field, they would be treated as a single polygon or zone. The 
values from the raster selected for the Input Value Raster Field (Peavy DEM) will be summarized for each of the polygons 
or zones that the raster cells overlap. 
 
Open the standelev table you just created. 
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The script at the bottom of the window tells us that we have 130 records represented. 
 
The first column gives us the STANDID number or unique stand unit identifier. Subsequent columns display the number 
of raster grid cells per stand unit, the area of the unit in square feet, and some summary statistics of elevation ranges for 
each unit. For example, we know that stand unit 040201 (the second stand record in the display above) averages 466 
feet in elevation. After you’re done browsing through this table, close it. 
 
Calculating and Analyzing Slope 
 
We can also use Spatial Analyst to create a slope surface from a DEM.  In the Geoprocessing window, search for Slope 
and select the Spatial Analyst Tools option. 
 

  
 
The Input Raster is Peavy DEM. Direct the output to McDonald.gdb and name it peavyslope. Change the Output 
measurement to Percent Rise - this will give us slope values as a percent rather than degrees. Click Run. 
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Rename the new layer Peavy Slope. Take a look at the new layer (you may have to turn the Stands layer off to see it). 
The legend automatically gives us eleven slope categories. 
 

 
 
We can use a histogram to better understand the distribution of slope values. Right click on Peavy Slope > Symbology. In 
the lower part of the Symbology window, click the Histogram tab. Click the More drop-down menu to experiment with 
reversing symbol order and values to your liking. 
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The histogram tells us that the majority of the area contains slopes in the first few categories (the lowest percent rise, 
therefore the lowest slope gradient). What would happen if we only had 9 percent rise categories, or 5? Click on the 
More drop down and select Show Statistics to bring up the raster statistics.  
 

 
 
Close the Symbology window. 
 
Save your project.  
 
Raster Properties 
 
From the Contents, right click Peavy DEM > Properties > Source tab. This opens a window telling you more information 
about the raster construction. The Source window tells you where this raster is stored, its resolution, coordinate system, 
and much more. 
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We can also tell that this is a permanent raster. When we use the Spatial Analyst to create new rasters without 
specifying an output location and file name, temporary rasters are usually created. Temporary rasters will typically be 
erased when you close your ArcGIS Pro session.  
 
There is also much information in the area below the Raster Information box. Most importantly is the Pixel Type field 
that tells us this is a Floating Point (or decimal place) raster. This means that there is no attribute table available for us to 
edit because values are continuous. If this were an integer raster, such as you would find with a discrete nominal or 
character variable, we would have access to an attribute table (like a shapefile). Cell size lists the number of units, feet in 
this case, per cell, and rows and columns sizes convey information about the size of this raster. Click OK.  
 
Save your map document before moving on. 
 
Calculating Average Slope Gradient 
 
As we just practiced, a unique Spatial Analyst feature is its ability to work with vector and raster layers in the same 
analysis. Let’s test this feature again by calculating the average slope for streams in the Peavy area. Search for Zonal 
Statistics as Table in the Geoprocessing Window. 
 
The Input Feature Zone Data is Streams, the Zone Field should be NAME, and the Input Value Raster is Peavy Slope. Save 
the output to McDonald.gdb and name it “streamstat.” 
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Open the streamstat table you just made. It should look like this: 
 

  
 
The results show that only two named streams exist in our current study area. Close this attribute table.   
 
Now calculate slope values for all the roads in our study area to produce a single set of statistics for all roads. First we 
need to create a common field in the Roads dataset to summarize on. Open the attribute table for the Roads layer and 
choose Add Field from the Options button. 
 
Enter “Summary” as the Field Name, change the Data Type to Short Integer and accept all other Defaults. Click Save in 
the Fields toolbar. 
 

 
 
Open the Roads attribute table and scroll to the end to view the new Summary field. Right click on the field header and 
choose Field Calculator. 
 
In the Calculate Field window, make Summary = 1 and click Run. All the cells in the Summary row should now display 1. 
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Close the Roads attribute table. Search for Zonal Statistics as Table in the Geoprocessing Window. The Input Feature 
Zone Data is Roads, the Zone Field is Summary and the Input Value Raster is Peavy Slope. Direct the output to 
McDonald.gdb with the name “roadstat.” 
 

   
 
Open the roadstat table from your Contents window after it appears. This table informs us that the average slope is over 
17 percent and the maximum slope value is over 66 percent. 
 

 
 
Close this table and save your project. 
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GIS LAB 7 Application: Calculating Elevation and Slope values for forested roads, streams, and stands. 
 
You will need to import a raster grid that represents elevation for all of McDonald Forest. This is called “elevgrid” and 
should be located in your workspace\gislab7\McDonald.gdb space after following the steps on Pages 3-4. If not, make 
sure it is imported into your McDonald geodatabase using the Raster to Geodatabase tool as we did earlier. Rename the 
raster McDonald DEM. The elevation units are in feet. 
 
Create a new data frame called McDonald Forest and add the following layers from your McDonald Geodatabase: 
McDonald DEM, Roads, Streams, Stands, and Boundary. 
 
All questions that follow refer only to areas within the borders of McDonald Forest.    
 
Assignment 7. This is a team assignment. Please answer the following questions. Type your answers and turn in at the 
beginning of the next lab meeting. Be sure to include your names, lab day and time (e.g. Tuesday 10 AM), assignment 
number, and course title with your answers. Create a table for questions with more than one response.  
 
Report measurements to the nearest whole unit only.  
 
Assignment 7A. 12 points. 
 
1. What is the average and standard deviation of elevation for areas within McDonald Forest? 
  
    
 
2.   Use the variable “standid” in the “Stands” layer to answer the following question. Which stand contains the third 
lowest elevation value and which stand contains the third highest? 
 
 
3. What is the average slope in percent for Baker Creek (use the NAME field in the streams layer) in McDonald Forest? 
You’ll need to derive a slope layer of McDonald Forest to answer this question. 
    
 
4.  What is the average slope, in percent, of rock roads in McDonald Forest? Use the field TYPE within the roads layer to 
determine where the rock roads are. 
   
 
5.  What is the average, minimum, and maximum elevation of stand 060710 (from the STANDID variable)? It may be 
helpful for you to create a shapefile that contains only the polygon(s) from this stand before running any statistical 
summaries. 
  
 
6.  What is the average, minimum, and maximum elevation of roads in stand 060710 (from the STANDID variable)? It 
may be helpful for you to create a shapefile that contains only the roads from this stand before running any statistical 
summaries. 
  
 
Assignment 7B. Create a map of McDonald Forest that shows the DEM in a five-category quantile distribution and 400 ft 
vertical contour lines. Include a legend for each layer in your map. Your map should contain an inset map that shows the 
McDonald Forest boundary within an outline of the state of Oregon (you can use the Oregon layer from Lab 6). All 
values on the map (DEM elevation categories and contour intervals) should not include decimals. Your map should 
also have a scale bar, north arrow, overall title, authors, date, and neat line. 5 points. 


